Use Proxifier v3.42 Print

  • proxifier, proxifier 3.42
  • 0

For those clients that wish to use Proxifier with their proxies, please note that version 4.07 of Proxifier is not compatible with our platform. Please only use version 3.42 which is available for download here: http://www.proxifier.com/download/legacy/ProxifierSetup342.exe

If you need a license for version 3.42, please contact our support staff and we will be happy to assist you with this.


Was this answer helpful?

« Back